АРМАДА
WordPress и Mysql
Новая тема Написать ответ Advanced Hosters - профессиональный хостинг

tonny
Свой
Зарегистрирован: 30.09.2008
Сообщений: 93
Обратиться по нику
# Добавлено:Пт Фев 20, 2009 2:48 amДобавить в избранноеОтветить с цитатой
Неожидано мой хостер сдулся и дал мне бэкапы моих блогов в виде непосредственно файлов и mysql баз.

Заказал новый хостинг, сами файлы залил, а вот с mysql сижу и мучаюсь уже пятый час: в конфиг файле всё поменял на новые данные, создал новую базу и пытаюсь импортировать в неё старую:

wp_comments, wp_links, wp_options появляются, а дальше прописывается ошибка "#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near...." Тут я и заглох, при заходе на сайт предлагается установить новый wp блог. Что делать? Где я опять сморозил (кроме выбора первого хостера)?

P.S. Буду благодарен за любую помощь, сайты уже в дауне как оказалось 4 дня и им осталось совсем немного до познания жизни вне индекса.

creator123
Гуру
Зарегистрирован: 25.07.2007
Сообщений: 1146
Обратиться по нику
# Добавлено:Пт Фев 20, 2009 8:08 amОтветить с цитатой
что в вышеуказанной строке в скрипте?
какая версия mysql была раньше и какая сейчас?
<----- если понравился пост, жмакай сюды <-----

Taburetkin
Гуру
Зарегистрирован: 25.02.2007
Сообщений: 1426
Star (Сумма: 1)
Обратиться по нику
# Добавлено:Пт Фев 20, 2009 8:31 amОтветить с цитатой
1064 ошибка это разные версии mySQL

The simplest and most effective solution for it is:

-when using phpMyadmin,select the "compatibility mode" & select the
target db version from the drop down box.
-when using MySql administrator,while backing up choose "compatibility
mode" in adavanced tab ,
and while restoring through mysql administrator ,click "auto-detect
file charater set" if backup was not made using mySql administrator.
the default file characer set used by mysql admministrator is utf8.

tonny
Свой
Зарегистрирован: 30.09.2008
Сообщений: 93
Обратиться по нику
# Добавлено:Пт Фев 20, 2009 1:30 pmОтветить с цитатой
Спасибо!
версия которая была пока не знаю, сейчас MySQL client version: 4.1.7

вот что пишет полностью:
Код:
#1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'Souza not only brings you news of the latest WordPress plugins and themes to hit' at line 1



Цитата:
1064 ошибка это разные версии mySQL

The simplest and most effective ...


При загрузке базы испробовал все варинты в Options (SQL compatibility mode), всё равно ошибка.

Странно то, что ещё как то в ноябре на одном из блогов проверял плагин для бэкапа и у меня как оказалось осталась sql база за тво время, вот она импортируется чудесно, но там не хватает огромного количества новостей да и других блогов таких баз нет Sad
айс

veligursky +
Гуру
Зарегистрирован: 14.07.2008
Сообщений: 1123
Обратиться по нику
# Добавлено:Пт Фев 20, 2009 1:50 pmОтветить с цитатой
сравни визуально два бекапа -тот что експортируется и тот что нет, проблема скорее всего в кавычках, и поправить можна с помощью обычного текстового редактора
Блог для Новичков в SEO и CPA, CPA Admitad

tonny
Свой
Зарегистрирован: 30.09.2008
Сообщений: 93
Обратиться по нику
# Добавлено:Пт Фев 20, 2009 2:43 pmОтветить с цитатой
базу всё-таки удалось импортнуть, нашёл часть sql базы которая вызывала ошибку и заменил её тойже частью из нормальной sql базы (которую делал в ноябре). таким образом получилось востановить все посты.

теперь новая проблема - при любой кодировке (пробовал самые распространённые; указывал при импорте базы) показываются знаки вопроса вместо русского текста, при просмотре файла через текстовый редактор та же фигня. возможно ли что сам текст постов я никак не востановлю?
айс

Dark Elf +
V.I.P.
Зарегистрирован: 23.12.2007
Сообщений: 1545
Обратиться по нику
# Добавлено:Пт Фев 20, 2009 5:49 pmОтветить с цитатой
tonny, Создаешь пустую базу, заходишь в phpmyadmin и меняешь кодировку на utf_unicode_ci потом импортируешь свой бекап и присязываешь базу к ВП.
Мой старый блог про адалт-блоги
Тёмные — это те, кто хочет свободы и независимости, не стремятся к власти, не навязывают своих глупых желаний окружающим.

tonny
Свой
Зарегистрирован: 30.09.2008
Сообщений: 93
Обратиться по нику
# Добавлено:Пт Фев 20, 2009 8:21 pmОтветить с цитатой
перевёл (database->operations->collations), не помогло всё равно знаки вопроса... походу действительно посты уже запорол, придётся из кэша гугла востанавливать, верно? или что-то ещё можно попробовать?
айс

RedHead
Свой
Зарегистрирован: 08.01.2008
Сообщений: 54
Обратиться по нику
# Добавлено:Пт Фев 20, 2009 8:36 pmОтветить с цитатой
попробовать на локалхосте поднять, експортануть в хml и импортнуть на чистый вордпрес. возможно настройки пхп\мускула на новой хосте что-то блочат или гдето привязка до старого урл. хотя маловероятно.

попробуйте открыть блокнотом базу, только не простым,там Notepad++ например, если и там иероглифы то дело совсем плохо..

tonny
Свой
Зарегистрирован: 30.09.2008
Сообщений: 93
Обратиться по нику
# Добавлено:Пт Фев 20, 2009 8:42 pmОтветить с цитатой
Цитата:
попробуйте открыть блокнотом базу, только не простым,там Notepad++ например, если и там иероглифы то дело совсем плохо..



открывал, знаки вопроса(( также через ворд смотрел сам файл в разных кодировках, везде либо вопросы, либо другие одинаковые символы что указывает на невозможность востановления. вроде всё возможное попробовал - безрезультатно, буду востанавливать из кэша
айс
Новая тема Написать ответ    ГЛАВНАЯ ~ ТЕХНИЧЕСКИЕ ВОПРОСЫ

Перейти:  





Генеральный спонсор



Партнеры