АРМАДА
Версия Php
Новая тема Написать ответ Advanced Hosters - профессиональный хостинг

Potapych
Свой
Зарегистрирован: 23.04.2012
Сообщений: 98
Обратиться по нику
# Добавлено:Чт Ноя 01, 2012 8:04 amДобавить в избранноеОтветить с цитатой
У кого какая версия php стоит на хостингах и есть ли проблемы с новыми версиями ?

Для одного нужного мне скрипта требуется php 5.3
Сейчас стоит у меня 5.2.x

Стоит ли обновлятся и до какой версии (5.3 - 5.4)? Знаю что 5.3 не подерживает Зенд и поэтому могут быть траблы

В ответах буду признателен если будете писать, какие скрипты у вас незапустились или плохо работают и на какой версии?

Toulan
V.I.P.
Зарегистрирован: 12.07.2012
Сообщений: 1603
Обратиться по нику
# Добавлено:Чт Ноя 01, 2012 8:43 amОтветить с цитатой
Простите чайника но, что такое Зенд и зачем он нужен?

Potapych
Свой
Зарегистрирован: 23.04.2012
Сообщений: 98
Обратиться по нику
# Добавлено:Чт Ноя 01, 2012 8:50 amОтветить с цитатой
Зенд Оптимизатор - используется для кодирования кода в скриптах т.е для защиты кода
Уникальная партнерка - нет аналогов в рунете!

Polaris
V.I.P.
Зарегистрирован: 23.03.2010
Сообщений: 2187
Обратиться по нику
# Добавлено:Чт Ноя 01, 2012 9:07 amОтветить с цитатой
Цитата:
Знаю что 5.3 не подерживает Зенд и поэтому могут быть траблы


Проблема с Zend Optimizer решается заменой на Zend Guard Loader. Правда скрипты закодированы для ZO не совместимы в ZGL и их нужно перекодировать с помощью Zend Guard,при условии наличия исходников.

Editeur
Опытный
Зарегистрирован: 19.06.2010
Сообщений: 382
Обратиться по нику
# Добавлено:Чт Ноя 01, 2012 11:35 pmОтветить с цитатой
В 5.3 нет ничего особенного, большинство скриптов должны подолжать работать. Зенд правда не работает. В 5.4 добавлено много интересного, замыкания например, и фиксы старых багов php, вроде невозможности конструкции foo(bar)[x]. Еще там всякий тянущийся с четвертой версии кал, кторый раньше генерировал предупреждения, теперь генерирует ошибки.
Если у нет скриптов, написанных специально под 5.4, я бы пока апгрейдиться выше 5.3 не стал.

awm543322445
V.I.P.
Зарегистрирован: 31.05.2012
Сообщений: 7303
Обратиться по нику
# Добавлено:Пт Ноя 02, 2012 1:53 amОтветить с цитатой
php 5.3 работает намного быстрее, по моим наблюдениям чем 5.2 :thup: 5,4 еще не юзал, да и рано еще на него переходить. Что за скрипты нужно крутить?
Сторонникам Морали и Нравственности нужно немедленно отрезать хуй, потому что хуй -- это безнравственно.

Coooler
V.I.P.
Зарегистрирован: 21.06.2010
Сообщений: 2786
Обратиться по нику
# Добавлено:Пт Ноя 02, 2012 8:21 amОтветить с цитатой
Кому интересно, переход с PHP 4 на PHP 5.0.x. Отличия, новые функции, а так же руководство по миграции для версий PHP 5.1.x, 5.2.x и 5.3.x.

Potapych
Свой
Зарегистрирован: 23.04.2012
Сообщений: 98
Обратиться по нику
# Добавлено:Пт Ноя 02, 2012 12:17 pmОтветить с цитатой
читал где то что на одном серваке можно юзать две версии Php ..У админов спросил - сказали что - да -можно
т.е. для каких то папок/доменов будет работать 5.2.x а для каких то 5.3.x
попробую так и зделать наверно
Уникальная партнерка - нет аналогов в рунете!
Новая тема Написать ответ    ГЛАВНАЯ ~ ТЕХНИЧЕСКИЕ ВОПРОСЫ

Перейти:  





Генеральный спонсор



Партнеры